Mate logging string doesn't match display

A Discussion about Mate to computer serial communications.

Moderators: OutBack Moderator Team, OutBack

Post Reply
Dave2006
Forum Junior Member
Posts: 3
Joined: Sat Oct 30, 2021 3:42 pm
My RE system: 2 each (GVFX7248 + MX60) + MATE 2 (rev 350)

Mate logging string doesn't match display

Post by Dave2006 »

My Mate 2 claims to be running version 350 software, unchanged from the 2006 install. I'm pulling the Mate logging strings, which make no sense. I'm reading the Mate Serial Communications Guide (This guide is only relevant to Mate Code Revs. of 4.00 and greater) so I'd expect some differences, but e.g. the display on the Mate says the MX is running PV=97.4v & 1a, but the logging string is completely different, no 97 anywhere within:
"FX1": "1,00,00,00,126,125,00,03,000,02,540,024,000,038",
"FX2": "2,00,00,05,122,122,00,10,000,02,540,024,000,035",
"MX1": "D,00,00,00,004,062,00,00,000,00,542,000,000,043",
"MX2": "E,00,00,00,005,056,00,00,000,00,541,000,000,047",
btw, the checksums match, so I'm reasonably sure the data is coming across okay.
Questions:
  • Is this a common problem
    Is it just broken and hopeless
    Or is there some reset I can perform to get it functional
raysun
Forum Overlord
Posts: 10865
Joined: Tue Jul 26, 2016 5:57 am
My RE system: Flexpower Two: (2) FXR3048A-01 - Series Stacked, (2) FM80, MATE3s, FlexNetDC
6 SimpliPhi 3.8-48 (48v @ 75AH. 450AH total)
Outback IBR3 battery enclosure
REC Alpha 440W panels - 2 arrays: each of 4 strings of 2 in series
2 Midnite Solar MNPV6 combiners w/20A DC disconnects.
Honda EU7000is gas fuel generator
Off-Grid

Re: Mate logging string doesn't match display

Post by raysun »

My Mate 2 claims to be running version 350 software, unchanged from the 2006 install. I'm pulling the Mate logging strings, which make no sense. I'm reading the Mate Serial Communications Guide (This guide is only relevant to Mate Code Revs. of 4.00 and greater)
What part doesn't make sense? The data, or the expectation that an incompatible firmware release will make sense of it?

Not sure what is trying to be done with the data, but you might want to trot over to the WattPlot site and check out the tools. Though Andrew is no longer actively supporting them, the entire suite is now license-free, and anything one is likely wanting to do, Andrew has likely already done it.

e.g.: https://wattplot.com/VisualMATE.htm
Dave2006
Forum Junior Member
Posts: 3
Joined: Sat Oct 30, 2021 3:42 pm
My RE system: 2 each (GVFX7248 + MX60) + MATE 2 (rev 350)

Re: Mate logging string doesn't match display

Post by Dave2006 »

Raysun, thanks for the pointer to Wattplot, but it's not what I'm looking for. I'm writing my own logger to integrate with the rest of my home automation.
raysun
Forum Overlord
Posts: 10865
Joined: Tue Jul 26, 2016 5:57 am
My RE system: Flexpower Two: (2) FXR3048A-01 - Series Stacked, (2) FM80, MATE3s, FlexNetDC
6 SimpliPhi 3.8-48 (48v @ 75AH. 450AH total)
Outback IBR3 battery enclosure
REC Alpha 440W panels - 2 arrays: each of 4 strings of 2 in series
2 Midnite Solar MNPV6 combiners w/20A DC disconnects.
Honda EU7000is gas fuel generator
Off-Grid

Re: Mate logging string doesn't match display

Post by raysun »

Dave2006 wrote: Mon Nov 01, 2021 9:11 pm Raysun, thanks for the pointer to Wattplot, but it's not what I'm looking for. I'm writing my own logger to integrate with the rest of my home automation.
Good luck!
Dave2006
Forum Junior Member
Posts: 3
Joined: Sat Oct 30, 2021 3:42 pm
My RE system: 2 each (GVFX7248 + MX60) + MATE 2 (rev 350)

Re: Mate logging string doesn't match display

Post by Dave2006 »

For anyone following along, this turned out to be a serial port buffering problem in pyserial-asyncio. I was logging once a minute, and thought I was turning off the serial port between reads. But no. Upon restart, I was getting stale data that was sometimes hours old. Now I'm continuously reading, and tossing data I don't want. Wasteful, but works.

I may go to pyMATE for finer detail, after reading about Outback and WattPlot.
User avatar
intellact
Forum Czar
Posts: 765
Joined: Mon Nov 28, 2005 3:20 am
My RE system: GVFX 3624 and MATE/MATE3/AXS Port with four Surette flooded lead-acid batteries (24V). Deactivated wind turbine. System now acts as UPS back-up. Monitored by WattPlot, of course.
Location: Ontario, Canada
Contact:

Re: Mate logging string doesn't match display

Post by intellact »

Your update is now a few years old, so this may be irrelevant to you but useful to others...?...

Earlier versions of WattPlot (now out there for free download) offered a per-minute summary file, where WattPlot would write the state of the system out to a file every minute. One user requested this so that their website could easily access their OutBack system status and display it using cool gauge gadgets (in older days before OPTICSre etc.). :cool:

As raysun said, "anything one is likely wanting to do, Andrew has likely already done it." :grin:
Andrew Welch, creator of WattPlot
Post Reply