Search and forum behavior

Website & Forum Discussions
Check here for our Welcome Message

Moderators: administrator, OutBack Moderator Team, OutBack

Post Reply
raysun
Forum Emperor
Posts: 3327
Joined: Tue Jul 26, 2016 5:57 am
My RE system: Flexpower Two: (2) FXR3048A, (2) FM80, MATE3s, FlexNetDC
SimpliPhi 48-3.8 (6 @ 48v)
Outback IBR3 battery enclosure
Suniva 330 watt panels (12 - 6 strings of 2 in series)
Hyundai 355 watt panels (6 - 3 strings of 2 in series)
Honda EU7000is gas fuel generator

Search and forum behavior

Post by raysun »

I do not intend this to be a rant post...

The forum's search feature has traditionally been inadequate, and rarely returns the posts I am looking for. That's not unusual for forum search engines, rarely do I find them useful.

My standard fallback is to use Google, and navigate to the posts of interest by the URLs returned. The Outback forum Viewpost function supported this quite neatly in the past.

Now with the switch to the new forum server, the Viewpost URLs are not working, and default to the main index page.

Can the Viewpost function be returned to its former functionality for external queries? (I suspect an index problem.)
provo
Forum Czar
Posts: 589
Joined: Thu Jul 27, 2006 4:34 pm
My RE system: Sixteen Evergreen EC-120
(4 strings, total 1920W)
Eight Rolls S-550 (2 strings, total ~800Ah @ 24V)
One FM80
One VFXR3524A
Hub 10
Mate3s
FNDC and Trimetric
Honda EU3000is generator
Location: Sierra foothills

Re: Search and forum behavior

Post by provo »

Ouch! I second your concern!

Using Google search and including "Outback Power" in the search line always worked well. To see the new problem, do a search on "outback power view topic". You'll see several hits, and even be able to read a bit of them, but clicking on anything just takes you to the main forum page, as raysun says.
BruceS
Forum Virtuoso
Posts: 87
Joined: Tue May 08, 2018 2:33 am
My RE system: Houseboat
6 X 250w X 24V panels ... Outback Inverter 24V X 3Kva (VFX3024E) ... Conext MPPT 60 150 solar controller .... Honda EU6.5i generator (manual start) ... 12 X 2V @ 600Ahr Sonnenschein Batteries ... Shore power facility ... Auto changeover between inverter/shore & genny.
Location: Mannum, Sth Australia, 5238

Re: Search and forum behavior

Post by BruceS »

It'll take all the search engine (& in particular Google) to re-index all the data.
Some search engines look for changes daily, some might be weekly etc.

Cristian?? https://www.reliablesoft.net/force-google-crawl-a-site/
User avatar
David LeBow
OutBack Management
Posts: 607
Joined: Sun May 03, 2015 10:42 am
Location: Bellingham, WA

Re: Search and forum behavior

Post by David LeBow »

raysun wrote: Sat Nov 21, 2020 11:22 am The forum's search feature has traditionally been inadequate, and rarely returns the posts I am looking for. That's not unusual for forum search engines, rarely do I find them useful.
Let me see what I can do to address (ok, "address") these issues. First: whatever search functionality the underlying forum engine (here, phpBB) provides us is what we have. Improving upon that is outside the scope of our day jobs. But: see also below.
raysun wrote: Sat Nov 21, 2020 11:22 am My standard fallback is to use Google, and navigate to the posts of interest by the URLs returned. The Outback forum Viewpost function supported this quite neatly in the past.

Now with the switch to the new forum server, the Viewpost URLs are not working, and default to the main index page.
Unfortunately, I'm not really clear on what you're referring to with the "OutBack Forum Viewpost function" and "Viewpost URLs". Could you put some additional meat on those diagnostic bones for me?
raysun wrote: Sat Nov 21, 2020 11:22 am Can the Viewpost function be returned to its former functionality for external queries? (I suspect an index problem.)
What I can say: we haven't specifically done anything to undo or worsen functionality. We did update to the latest version of the phpBB engine during the shift to a new hosting mechanism, since the patched versions always contain security fixes. It's not impossible that some setting on the new server isn't the same as on the old - that's what happened with the document download. Some files worked, others didn't: turns out that case sensitivity wasn't configured identically on the new server, so filenames didn't match 100% (OutBack <> outback).

It's not impossible that there's some similar setting we need to dig into. We did take the opportunity to rebuild all of the indices while we had the site down.

A lot of words, no real solution. If you could give me any details on what used to work and examples of what aren't, I can see if we can dig in deeper.
David LeBow
Sr. Director, Software Engineering


Alpha Technologies Inc. / OutBack Power Technologies
3767 Alpha Way Bellingham WA 98226 USA
http://www.alpha.com
raysun
Forum Emperor
Posts: 3327
Joined: Tue Jul 26, 2016 5:57 am
My RE system: Flexpower Two: (2) FXR3048A, (2) FM80, MATE3s, FlexNetDC
SimpliPhi 48-3.8 (6 @ 48v)
Outback IBR3 battery enclosure
Suniva 330 watt panels (12 - 6 strings of 2 in series)
Hyundai 355 watt panels (6 - 3 strings of 2 in series)
Honda EU7000is gas fuel generator

Re: Search and forum behavior

Post by raysun »

Yes, the forum software's search engine is what we are talking about here. I know of no forum software that includes a search engine that returns excellent results. Mediocre seems to be the quality target for forum developers.

Hence the reliance on outside search engines like google. Below is a result from a typical "Forum search" via google:
Screenshot_20201122-110658_Google.jpg
Sorry for the confusion in nomenclature. The actual command is "viewtopic". When clicking in the search result:
Screenshot_20201122-110706_Chrome.jpg
The forum returns the main page. No errors, which leads me to believe this is default behavior when the record cannot be found in the forum. A typical reason for a "no records returned" condition is a missing or corrupt index. The admins might be able to check on that.
User avatar
David LeBow
OutBack Management
Posts: 607
Joined: Sun May 03, 2015 10:42 am
Location: Bellingham, WA

Re: Search and forum behavior

Post by David LeBow »

For my own understanding (and just as much for the web archaeologists who come behind me). I tried googling this: "not feeding the grid outback" in Google. That turned up the following:
ForumSearch1.jpg
Copying the link address gets me this: http://outbackpower.com/forum/viewtopic.php?t=14872

Clicking that link on the google page does indeed take me to the forum index. Bad.

If I copy/paste that link to another browser page... it gets me to the same place. Bad.

Explicitly changing the http to https didn't improve anything, though I didn't really expect that it would. Still bad.

Aha... getting somewhere. If I navigate through the forum index to some post, that uses the following link structure: https://forum.outbackpower.com/viewtopic.php?f=7&t=2771

It looks like google is still holding the olde style link layout from the last time it indexed our site. The same is probably true of other search engines - until we're reindexed.

@Cristian: is there a way to poke search engines in the eye in order to "request" a re-index pass for restructurings of this type?

Then, to complete the pass, I went and searched for "not feeding the grid" (dropping "OutBack") in the forum's search box and came up with - among other things - this:
ForumSearch2.jpg
So: Google 0, OutBack Forum Search 1 at the end of the 3rd quarter. I'm guessing that we need to somehow "request" a re-index or we just need to wait for the forum to come around again on the geetar and be sucked up into the search engine maw.

Make sense?
David LeBow
Sr. Director, Software Engineering


Alpha Technologies Inc. / OutBack Power Technologies
3767 Alpha Way Bellingham WA 98226 USA
http://www.alpha.com
raysun
Forum Emperor
Posts: 3327
Joined: Tue Jul 26, 2016 5:57 am
My RE system: Flexpower Two: (2) FXR3048A, (2) FM80, MATE3s, FlexNetDC
SimpliPhi 48-3.8 (6 @ 48v)
Outback IBR3 battery enclosure
Suniva 330 watt panels (12 - 6 strings of 2 in series)
Hyundai 355 watt panels (6 - 3 strings of 2 in series)
Honda EU7000is gas fuel generator

Re: Search and forum behavior

Post by raysun »

David LeBow wrote: Sun Nov 22, 2020 1:59 pm For my own understanding (and just as much for the web archaeologists who come behind me). I tried googling this: "not feeding the grid outback" in Google. That turned up the following:

ForumSearch1.jpg

Copying the link address gets me this: http://outbackpower.com/forum/viewtopic.php?t=14872

Clicking that link on the google page does indeed take me to the forum index. Bad.

If I copy/paste that link to another browser page... it gets me to the same place. Bad.

Explicitly changing the http to https didn't improve anything, though I didn't really expect that it would. Still bad.

Aha... getting somewhere. If I navigate through the forum index to some post, that uses the following link structure: https://forum.outbackpower.com/viewtopic.php?f=7&t=2771

It looks like google is still holding the olde style link layout from the last time it indexed our site. The same is probably true of other search engines - until we're reindexed.

@Cristian: is there a way to poke search engines in the eye in order to "request" a re-index pass for restructurings of this type?

Then, to complete the pass, I went and searched for "not feeding the grid" (dropping "OutBack") in the forum's search box and came up with - among other things - this:

ForumSearch2.jpg

So: Google 0, OutBack Forum Search 1 at the end of the 3rd quarter. I'm guessing that we need to somehow "request" a re-index or we just need to wait for the forum to come around again on the geetar and be sucked up into the search engine maw.

Make sense?
Yes, makes sense.

Another knuckleball:
When searching the forum using the internal search engine, I can't figure out how to get results other than posts from 2020. The prior years don't seem to be included.

For example: From the topmost Forum Index, searching for FX3048T (with search parameter "ALL" selected for the time frame), Search returns 33 results, the oldest being January 2020.
User avatar
David LeBow
OutBack Management
Posts: 607
Joined: Sun May 03, 2015 10:42 am
Location: Bellingham, WA

Re: Search and forum behavior

Post by David LeBow »

<hits the knuckleball into the dirt, 0 and 1>: Do you know of any posts pre-2020 which should match that? (I know... it's Search which should tell you that, but... just trying to narrow things down for the web archaeologist...).
David LeBow
Sr. Director, Software Engineering


Alpha Technologies Inc. / OutBack Power Technologies
3767 Alpha Way Bellingham WA 98226 USA
http://www.alpha.com
raysun
Forum Emperor
Posts: 3327
Joined: Tue Jul 26, 2016 5:57 am
My RE system: Flexpower Two: (2) FXR3048A, (2) FM80, MATE3s, FlexNetDC
SimpliPhi 48-3.8 (6 @ 48v)
Outback IBR3 battery enclosure
Suniva 330 watt panels (12 - 6 strings of 2 in series)
Hyundai 355 watt panels (6 - 3 strings of 2 in series)
Honda EU7000is gas fuel generator

Re: Search and forum behavior

Post by raysun »

David LeBow wrote: Sun Nov 22, 2020 2:46 pm <hits the knuckleball into the dirt, 1 and 0>: Do you know of any posts pre-2020 which should match that? (I know... it's Search which should tell you that, but... just trying to narrow things down for the web archaeologist...).
Here's one:
viewtopic.php?p=53190#p53190

Also, if a search is done on Author, all posts they have created are returned.

Search done on Keyword and Author restricts results to 2020.
User avatar
David LeBow
OutBack Management
Posts: 607
Joined: Sun May 03, 2015 10:42 am
Location: Bellingham, WA

Re: Search and forum behavior

Post by David LeBow »

Welp... I've scoured all the possible board settings and googled my brains out. I don't see any really clear explanation for this. But: I've deleted and am now recreating the board's search engine index. Not sure how long that will last. Could easily be some number of hours with a board of this size.

Here's hoping for some eventual improvement.
David LeBow
Sr. Director, Software Engineering


Alpha Technologies Inc. / OutBack Power Technologies
3767 Alpha Way Bellingham WA 98226 USA
http://www.alpha.com
raysun
Forum Emperor
Posts: 3327
Joined: Tue Jul 26, 2016 5:57 am
My RE system: Flexpower Two: (2) FXR3048A, (2) FM80, MATE3s, FlexNetDC
SimpliPhi 48-3.8 (6 @ 48v)
Outback IBR3 battery enclosure
Suniva 330 watt panels (12 - 6 strings of 2 in series)
Hyundai 355 watt panels (6 - 3 strings of 2 in series)
Honda EU7000is gas fuel generator

Re: Search and forum behavior

Post by raysun »

Thanks David!
User avatar
David LeBow
OutBack Management
Posts: 607
Joined: Sun May 03, 2015 10:42 am
Location: Bellingham, WA

Re: Search and forum behavior

Post by David LeBow »

Well... don't thank me yet. I see that the index rebuild is still ongoing. Not sure if it'll get better or not...
David LeBow
Sr. Director, Software Engineering


Alpha Technologies Inc. / OutBack Power Technologies
3767 Alpha Way Bellingham WA 98226 USA
http://www.alpha.com
User avatar
David LeBow
OutBack Management
Posts: 607
Joined: Sun May 03, 2015 10:42 am
Location: Bellingham, WA

Re: Search and forum behavior

Post by David LeBow »

Yikes... seems like that index is still rebuilding!
David LeBow
Sr. Director, Software Engineering


Alpha Technologies Inc. / OutBack Power Technologies
3767 Alpha Way Bellingham WA 98226 USA
http://www.alpha.com
raysun
Forum Emperor
Posts: 3327
Joined: Tue Jul 26, 2016 5:57 am
My RE system: Flexpower Two: (2) FXR3048A, (2) FM80, MATE3s, FlexNetDC
SimpliPhi 48-3.8 (6 @ 48v)
Outback IBR3 battery enclosure
Suniva 330 watt panels (12 - 6 strings of 2 in series)
Hyundai 355 watt panels (6 - 3 strings of 2 in series)
Honda EU7000is gas fuel generator

Re: Search and forum behavior

Post by raysun »

David LeBow wrote: Wed Nov 25, 2020 12:23 pm Yikes... seems like that index is still rebuilding!
There's a lot of posts!
fcwlp
Forum Czar
Posts: 648
Joined: Wed Jan 22, 2020 9:40 am
My RE system: GS8048A, FM80 w/3,600W PV Fixed, FM80 w/2,700W on Zomeworks tracker, Mate3, 24 Trojan 2V L16 1100AH @ C20, Grid-Tied with Kohler 14RESA LPG Generator and MEP-803 Diesel if needed.

I install and maintain grid-tied and off-grid systems in my area and consult on solar system design/operation.
Location: 80 miles NE of Phoenix at 5500'

Re: Search and forum behavior

Post by fcwlp »

Maybe it is the re-indexing. I just searched for something and only got results from 2003-2005. :grin:
raysun
Forum Emperor
Posts: 3327
Joined: Tue Jul 26, 2016 5:57 am
My RE system: Flexpower Two: (2) FXR3048A, (2) FM80, MATE3s, FlexNetDC
SimpliPhi 48-3.8 (6 @ 48v)
Outback IBR3 battery enclosure
Suniva 330 watt panels (12 - 6 strings of 2 in series)
Hyundai 355 watt panels (6 - 3 strings of 2 in series)
Honda EU7000is gas fuel generator

Re: Search and forum behavior

Post by raysun »

fcwlp wrote: Wed Nov 25, 2020 3:00 pm Maybe it is the re-indexing. I just searched for something and only got results from 2003-2005. :grin:
That's a start! Literally.
raysun
Forum Emperor
Posts: 3327
Joined: Tue Jul 26, 2016 5:57 am
My RE system: Flexpower Two: (2) FXR3048A, (2) FM80, MATE3s, FlexNetDC
SimpliPhi 48-3.8 (6 @ 48v)
Outback IBR3 battery enclosure
Suniva 330 watt panels (12 - 6 strings of 2 in series)
Hyundai 355 watt panels (6 - 3 strings of 2 in series)
Honda EU7000is gas fuel generator

Re: Search and forum behavior

Post by raysun »

As indexing chugs along to its, hopefully, complete and uncorrupted future state, it shows interesting promise.

Search for Lithium.

Sort of Alpha and Omega I'd think.
20201125_194751.jpg
User avatar
David LeBow
OutBack Management
Posts: 607
Joined: Sun May 03, 2015 10:42 am
Location: Bellingham, WA

Re: Search and forum behavior

Post by David LeBow »

Seems like the @#@$ thing is still indexing..!

Hope the results are getting better.

D.
David LeBow
Sr. Director, Software Engineering


Alpha Technologies Inc. / OutBack Power Technologies
3767 Alpha Way Bellingham WA 98226 USA
http://www.alpha.com
raysun
Forum Emperor
Posts: 3327
Joined: Tue Jul 26, 2016 5:57 am
My RE system: Flexpower Two: (2) FXR3048A, (2) FM80, MATE3s, FlexNetDC
SimpliPhi 48-3.8 (6 @ 48v)
Outback IBR3 battery enclosure
Suniva 330 watt panels (12 - 6 strings of 2 in series)
Hyundai 355 watt panels (6 - 3 strings of 2 in series)
Honda EU7000is gas fuel generator

Re: Search and forum behavior

Post by raysun »

David LeBow wrote: Tue Dec 01, 2020 11:11 am Seems like the @#@$ thing is still indexing..!

Hope the results are getting better.

D.
Indexing can be a 'watching paint dry' affair.

Searching "Lithium" the other day returned 2 records. One from 2005 and one from the current date.

Today it returns 19, no, 20 records. One from 2005, and the rest from 2020 (including this one.)

Progress.
Post Reply