Page 1 of 1

Battery Monitor issue

Posted: Fri Apr 10, 2020 4:24 am
by wpmaura
Just got this thing set up, but its telling me batteries are 100 percent and there not its also telling me voltage is 49.6, I have 12 12v 100amh agm in a 48v bank set up. any help on this. I went through the wizard and all seems normal.

Re: Battery Monitor issue

Posted: Fri Apr 10, 2020 8:50 am
by raysun
There's info on your other post.

Re: Battery Monitor issue

Posted: Fri Apr 10, 2020 9:12 am
by sparksalot
wpmaura wrote: Fri Apr 10, 2020 4:24 am Just got this thing set up, but its telling me batteries are 100 percent and there not its also telling me voltage is 49.6, I have 12 12v 100amh agm in a 48v bank set up. any help on this. I went through the wizard and all seems normal.
For your 100% issue:
viewtopic.php?p=50642#p50642

Fully charged 48VDC battery will be or read near to ~54VDC

Re: Battery Monitor issue

Posted: Fri Apr 10, 2020 2:49 pm
by wpmaura
sparksalot wrote: Fri Apr 10, 2020 9:12 am
wpmaura wrote: Fri Apr 10, 2020 4:24 am Just got this thing set up, but its telling me batteries are 100 percent and there not its also telling me voltage is 49.6, I have 12 12v 100amh agm in a 48v bank set up. any help on this. I went through the wizard and all seems normal.
For your 100% issue:
viewtopic.php?p=50642#p50642

Fully charged 48VDC battery will be or read near to ~54VDC
Not sure about that 54v. Never got anywhere near there these are agms I think its closer to 51.2

Re: Battery Monitor issue

Posted: Fri Apr 10, 2020 7:04 pm
by sparksalot
wpmaura wrote: Fri Apr 10, 2020 2:49 pm
sparksalot wrote: Fri Apr 10, 2020 9:12 am
wpmaura wrote: Fri Apr 10, 2020 4:24 am Just got this thing set up, but its telling me batteries are 100 percent and there not its also telling me voltage is 49.6, I have 12 12v 100amh agm in a 48v bank set up. any help on this. I went through the wizard and all seems normal.
For your 100% issue:
viewtopic.php?p=50642#p50642

Fully charged 48VDC battery will be or read near to ~54VDC
Not sure about that 54v. Never got anywhere near there these are agms I think its closer to 51.2
Gotcha, but the take away is that your 49.6V is not nearly charged full...but at least now you know how to get it fine tuned for a better 100% display.

Re: Battery Monitor issue

Posted: Sat Jun 20, 2020 6:20 am
by Lewis-H
I never dived deep into custom settings staying with defaults. Indeed, absorb to float stage trigger is time based, not current. I set battery type, voltages, and capacity and go. Charging efficiency is set to default Auto.

I never felt that I needed to use custom set-up, SOC is very consistent in similar charging conditions day by day.

I did have a problem a few years back with a code displayed (don’t remember the number). With Magnum service folk’s assistance, I was able to bring the system back to life. It was inconclusive what was the problem, could be overheating. It works flawlessly since. I hope I answered your questions, if not I can dig more but I am far away.