Mate3s 001.004.007 firmware update

Mate3 and Mate3s communications devices for Outback Power
Post Reply
User avatar
Megunticook
Forum Guru
Posts: 356
Joined: Fri Sep 29, 2017 4:08 am
My RE system: 6.4 kW solar array (21 QCell 305 panels in strings of 3)
GS8048A FLEXpower Radian (Radian 8048A, 2 FlexMax 80 cc's, Mate 3s, FlexNet DC, Hub)
8x6v Rolls-Surette 550 FLA batteries, 428AH
Location: Maine
Contact:

Mate3s 001.004.007 firmware update

Post by Megunticook »

Has anybody installed this update? Any issues?

Just thought I'd check before taking the plunge. Thanks.
https://sunnypower.org
santafedave
Forum Virtuoso
Posts: 91
Joined: Sat Dec 05, 2020 8:05 pm
My RE system: GS8048-A-300AFCI 8 KW 48V Mate3s with 2 FM100 charge controllers pre wired.
21 Canadian Solar 320 Watt PERC MC4 CS3K-320MS panels.
3 Canadian Solar 325W Module Mono Perc 1000VDC panels.
8 FullRiver AGM DC400-6 Sealed Batteries 415AH 6V L16 size.
Fireraptor quick disconnect.

Re: Mate3s 001.004.007 firmware update

Post by santafedave »

Still waiting myself.
provo
Forum Emperor
Posts: 1105
Joined: Thu Jul 27, 2006 4:34 pm
My RE system: 16 Evergreen EC-120 (4 strings, total 1920W)
2 SimpliPhi 3.8-m-24V (150Ah each)
One FM80
One VFXR3524A
Hub 10
Mate3s
FNDC
Honda EU3000is generator
Location: Sierra foothills

Re: Mate3s 001.004.007 firmware update

Post by provo »

I installed it yesterday after reading your post. No problems so far, except Optics still says I'm on 1.4.6 this morning. The Mate3s webpage showed a successful upgrade to 1.4.7 immediately after I did it.

Maybe Optics always takes a few days? I don't remember that in the past, but there's I lot I don't remember :-).
User avatar
David LeBow
OutBack Management
Posts: 661
Joined: Sun May 03, 2015 10:42 am
Location: Bellingham, WA

Re: Mate3s 001.004.007 firmware update

Post by David LeBow »

provo wrote: Mon Oct 18, 2021 8:46 am No problems so far, except Optics still says I'm on 1.4.6 this morning. The Mate3s webpage showed a successful upgrade to 1.4.7 immediately after I did it.

Maybe Optics always takes a few days? I don't remember that in the past, but there's I lot I don't remember :-).
Double check the version information on your Mate3S. There are two processors - the Ethernet processor and the main processors. Both should show as 1.4.7. If the upgrade wasn't "completely" successful, one processor may still be at the previous version. If so, you would want to repeat the upgrade process to see if it "takes" the second time around.
David LeBow
Sr. Director, Software Engineering


Alpha Technologies Inc. / OutBack Power Technologies
3767 Alpha Way Bellingham WA 98226 USA
http://www.alpha.com
provo
Forum Emperor
Posts: 1105
Joined: Thu Jul 27, 2006 4:34 pm
My RE system: 16 Evergreen EC-120 (4 strings, total 1920W)
2 SimpliPhi 3.8-m-24V (150Ah each)
One FM80
One VFXR3524A
Hub 10
Mate3s
FNDC
Honda EU3000is generator
Location: Sierra foothills

Re: Mate3s 001.004.007 firmware update

Post by provo »

David LeBow wrote: Mon Oct 18, 2021 9:42 am
Double check the version information on your Mate3S. There are two processors - the Ethernet processor and the main processors. Both should show as 1.4.7. If the upgrade wasn't "completely" successful, one processor may still be at the previous version. If so, you would want to repeat the upgrade process to see if it "takes" the second time around.

Thanks, Dave. This is what I'm seeing in the Mate3s device map, and the Devices panel under the gear menu says the same. Where do I see the ethernet vs main processor firmware versions?

Mate3s firmware.jpg
Found it! (on the Mate itself :grin: ) ... Mate is 1.4.7, ethernet is 1.4.6. I'll try again...
Last edited by provo on Mon Oct 18, 2021 1:49 pm, edited 1 time in total.
User avatar
David LeBow
OutBack Management
Posts: 661
Joined: Sun May 03, 2015 10:42 am
Location: Bellingham, WA

Re: Mate3s 001.004.007 firmware update

Post by David LeBow »

provo wrote: Mon Oct 18, 2021 1:43 pm
Thanks, Dave. This is what I'm seeing in the Mate3s device map, and the Devices panel under the gear menu says the same. Where do I see the ethernet vs main processor firmware versions?
On the Mate3S front panel itself.
David LeBow
Sr. Director, Software Engineering


Alpha Technologies Inc. / OutBack Power Technologies
3767 Alpha Way Bellingham WA 98226 USA
http://www.alpha.com
provo
Forum Emperor
Posts: 1105
Joined: Thu Jul 27, 2006 4:34 pm
My RE system: 16 Evergreen EC-120 (4 strings, total 1920W)
2 SimpliPhi 3.8-m-24V (150Ah each)
One FM80
One VFXR3524A
Hub 10
Mate3s
FNDC
Honda EU3000is generator
Location: Sierra foothills

Re: Mate3s 001.004.007 firmware update

Post by provo »

David LeBow wrote: Mon Oct 18, 2021 1:48 pm
On the Mate3S front panel itself.
OK, this time it worked. The first time I used the bootloader, which is often the only way that works. This time I used the "usual" method, and both processors are now at 1.4.7.

Thanks!
pss
Forum Emperor
Posts: 1020
Joined: Mon Jul 24, 2017 8:40 am
My RE system: 8330 watts in three strings, Flexmax 60 x 3, Radian 8048A, GSLC load center, Mate 3S, Hub 10.3, FN-DC and 900 Amp, 48V Trojan T105-RE battery bank.

Re: Mate3s 001.004.007 firmware update

Post by pss »

I was on 1.4.6 Mate 3S. After a power outage and some generator use and reboots, My Mate was acting erratically again. I removed the SD card and the ASCII characters were corrupted when viewed on Windows 10. I formatted the card, copied back my log files, extracted 1.4.7 to the SD card. I rebooted the Mate 3S. I installed the SD card, upgraded to the new firmware without difficulty and my Mate 3S now working perfectly.

I think from my experience that it is important when doing firmware update to mate 3S to only have the newest firmware upgrade on the SD card and if keeping the card in the system, your logfiles directory. Remove all old Mate 3S firmware files.

And thank you Outback for keep trying to debug the Mate 3S as i do experience all of the issues you try to fix.
justinbowditch
Forum Junior Member
Posts: 3
Joined: Mon Sep 27, 2021 12:15 pm
My RE system: 32 volt lip04 - Flex max 60 and FX2532MT inverter hub and Mate 3s connected

Re: Mate3s 001.004.007 firmware update

Post by justinbowditch »

Similar problem, mine was acting up also and now I'm getting 'can't find the sd card'
I'm using opticsre so the process involved reformatting the card to FAT, but I"m on a mac and the only choices I have are 'exFAT' and 'msdos FAT'.
Which one is it?
provo
Forum Emperor
Posts: 1105
Joined: Thu Jul 27, 2006 4:34 pm
My RE system: 16 Evergreen EC-120 (4 strings, total 1920W)
2 SimpliPhi 3.8-m-24V (150Ah each)
One FM80
One VFXR3524A
Hub 10
Mate3s
FNDC
Honda EU3000is generator
Location: Sierra foothills

Re: Mate3s 001.004.007 firmware update

Post by provo »

justinbowditch wrote: Thu Oct 21, 2021 11:25 am
Which one is it?
MS-DOS (FAT)
provo
Forum Emperor
Posts: 1105
Joined: Thu Jul 27, 2006 4:34 pm
My RE system: 16 Evergreen EC-120 (4 strings, total 1920W)
2 SimpliPhi 3.8-m-24V (150Ah each)
One FM80
One VFXR3524A
Hub 10
Mate3s
FNDC
Honda EU3000is generator
Location: Sierra foothills

Re: Mate3s 001.004.007 firmware update

Post by provo »

More detail here:

viewtopic.php?f=39&t=15763

Scroll down to Raysun's second post in the thread for the "bootloader" method.
User avatar
Megunticook
Forum Guru
Posts: 356
Joined: Fri Sep 29, 2017 4:08 am
My RE system: 6.4 kW solar array (21 QCell 305 panels in strings of 3)
GS8048A FLEXpower Radian (Radian 8048A, 2 FlexMax 80 cc's, Mate 3s, FlexNet DC, Hub)
8x6v Rolls-Surette 550 FLA batteries, 428AH
Location: Maine
Contact:

Re: Mate3s 001.004.007 firmware update

Post by Megunticook »

So I double checked my firmware version displayed in Optics and also directly on the MATE3s and noticing a discrepancy: Optics lists MATE3s firmware version as 1.4.7 but the MATE3s itself reports 1.4.6--see screenshots below:

Image

Which is accurate?

When I did the update I'm pretty sure I got a message saying the Ethernet Processor failed to update--happened again on the retry. But MATE3s is reporting 1.4.7 for Ethernet firmware.

Everything is working perfectly right now as far as I can tell.
https://sunnypower.org
provo
Forum Emperor
Posts: 1105
Joined: Thu Jul 27, 2006 4:34 pm
My RE system: 16 Evergreen EC-120 (4 strings, total 1920W)
2 SimpliPhi 3.8-m-24V (150Ah each)
One FM80
One VFXR3524A
Hub 10
Mate3s
FNDC
Honda EU3000is generator
Location: Sierra foothills

Re: Mate3s 001.004.007 firmware update

Post by provo »

See Dave LeBow's posts upthread. You might have to load the same firmware again to get both processors up to 1.4.7.
User avatar
Megunticook
Forum Guru
Posts: 356
Joined: Fri Sep 29, 2017 4:08 am
My RE system: 6.4 kW solar array (21 QCell 305 panels in strings of 3)
GS8048A FLEXpower Radian (Radian 8048A, 2 FlexMax 80 cc's, Mate 3s, FlexNet DC, Hub)
8x6v Rolls-Surette 550 FLA batteries, 428AH
Location: Maine
Contact:

Re: Mate3s 001.004.007 firmware update

Post by Megunticook »

Tried reinstalling 1.4.7 but fails every time no matter what I try. The failure is during the ethernet processor update phase, after about 30 seconds it says "file not found."

I re-downloaded the update from OB, unzipped it onto a newly-formatted SD card, verified the contents, and tried the update on the MATE--ethernet cable plugged in/out, after rebooting the MATE, etc.. Every time same error.

I suspect something is wrong with the MATE3s cardreader...but who knows. In any case everything seems to working fine so I'll just hang tight until 1.4.8 comes out and then try again. But am really wondering if this is a hardware issue, what with all the people having problems with their MATE3s being unable to read a card.
https://sunnypower.org
provo
Forum Emperor
Posts: 1105
Joined: Thu Jul 27, 2006 4:34 pm
My RE system: 16 Evergreen EC-120 (4 strings, total 1920W)
2 SimpliPhi 3.8-m-24V (150Ah each)
One FM80
One VFXR3524A
Hub 10
Mate3s
FNDC
Honda EU3000is generator
Location: Sierra foothills

Re: Mate3s 001.004.007 firmware update

Post by provo »

Megunticook wrote: Sun Nov 28, 2021 8:12 am
I re-downloaded the update from OB, unzipped it onto a newly-formatted SD card, verified the contents, and tried the update on the MATE--ethernet cable plugged in/out, after rebooting the MATE, etc.. Every time same error.
When you say "newly-formatted SD card", was it a different card, or the same one that failed before? Sometimes I have to try several. I've had the best luck with 2GB SanDisk cards.

Have you tried the "bootloader" method of installing firmware? (Power off the Mate, insert card, power on the Mate while pressing the UP key.)
User avatar
Megunticook
Forum Guru
Posts: 356
Joined: Fri Sep 29, 2017 4:08 am
My RE system: 6.4 kW solar array (21 QCell 305 panels in strings of 3)
GS8048A FLEXpower Radian (Radian 8048A, 2 FlexMax 80 cc's, Mate 3s, FlexNet DC, Hub)
8x6v Rolls-Surette 550 FLA batteries, 428AH
Location: Maine
Contact:

Re: Mate3s 001.004.007 firmware update

Post by Megunticook »

Tried multiple cards. This card reader thing has been going on for the better part of a year now for me.

I'll try that trick with rebooting while pressing the UP key. But at this point I may wait until 1.4.8--working great now so may as well leave well-enough alone.
https://sunnypower.org
pss
Forum Emperor
Posts: 1020
Joined: Mon Jul 24, 2017 8:40 am
My RE system: 8330 watts in three strings, Flexmax 60 x 3, Radian 8048A, GSLC load center, Mate 3S, Hub 10.3, FN-DC and 900 Amp, 48V Trojan T105-RE battery bank.

Re: Mate3s 001.004.007 firmware update

Post by pss »

Please make sure you unplug your Mate 3S Ethernet cable from your local network, then power cycle the mate and then try to flash firmware again.
JRHill
Forum Emperor
Posts: 2391
Joined: Thu Feb 17, 2011 11:12 am
My RE system: 48v OB inverter and charge controller, hub and mate3s.
Location: PNW
Contact:

Re: Mate3s 001.004.007 firmware update

Post by JRHill »

Whoa. Today I noticed in the Mate3s web page and the Mate3s itself confirmed:

Mate 3Firmware: 001.004.003
Port: 1FXR Firmware: 001.006.063
Port: 2FNDC Firmware: 001.001.071
Port: 3FM60/80 Firmware: 002.000.000

Well, OK, I knew there was an update but didn't. It appears the Mate3s is still back at 001.004.003 and the Ethernet is 001.004.006. I know I reflashed the Mate3s previously but I didn't pay attention to the detail from Mr. LeBow's comment - I thought I was all good.

So here I go, no big deal, I'll verify a complete and successful update to the Mate3s.

Next:
JRHill
Forum Emperor
Posts: 2391
Joined: Thu Feb 17, 2011 11:12 am
My RE system: 48v OB inverter and charge controller, hub and mate3s.
Location: PNW
Contact:

Re: Mate3s 001.004.007 firmware update

Post by JRHill »

JRHill wrote: Tue Jan 25, 2022 10:57 amNext:
The whole reason I was looking at firmware is the VFXR with which I've had certain problems. Its up to date but I downloaded the firmware again. Same version. I'm really hesitant to invoke this so I went looking. Mate3s Ops, Programming, VFXR and etc. What gets my attention is the updates seem to be around regional Grid Support files. In other words, regional things related to local grid connections. Nothing that the update could address a weirdity in off grid stuff. So I will NOT update anything related to the VFXR unless I know the basics would be addressed as well. One Oops and I could be screwed.

Any thoughts?
JRHill
Forum Emperor
Posts: 2391
Joined: Thu Feb 17, 2011 11:12 am
My RE system: 48v OB inverter and charge controller, hub and mate3s.
Location: PNW
Contact:

Re: Mate3s 001.004.007 firmware update

Post by JRHill »

Update:
Mate3s, Ethernet at 001.004.007. Successful.

As in past messages it could be the most simple, stupid stuff. I don't know yet. We'll see. I'll not say anything further.
User avatar
Megunticook
Forum Guru
Posts: 356
Joined: Fri Sep 29, 2017 4:08 am
My RE system: 6.4 kW solar array (21 QCell 305 panels in strings of 3)
GS8048A FLEXpower Radian (Radian 8048A, 2 FlexMax 80 cc's, Mate 3s, FlexNet DC, Hub)
8x6v Rolls-Surette 550 FLA batteries, 428AH
Location: Maine
Contact:

Re: Mate3s 001.004.007 firmware update

Post by Megunticook »

I went ahead and updated to 1.4.7 using the reboot with top button depressed method and it worked fine. Every time I tried to do it normally it said "SD Card not found."

These MATE3s's are whacked.
https://sunnypower.org
Post Reply