MATE3s can't read SD cards anymore

Mate3 and Mate3s communications devices for Outback Power
Post Reply
User avatar
Megunticook
Forum Guru
Posts: 266
Joined: Fri Sep 29, 2017 4:08 am
My RE system: 6.4 kW solar array (21 QCell 305 panels in strings of 3)
GS8048A FLEXpower Radian (Radian 8048A, 2 FlexMax 80 cc's, Mate 3s, FlexNet DC, Hub)
8x6v Rolls-Surette 550 FLA batteries, 428AH
Location: Maine
Contact:

MATE3s can't read SD cards anymore

Post by Megunticook »

In another thread here I detailed last fall the problems I had updating the MATE3s to the 1.4.5 firmware. Seemed like the MATE was having trouble reading the SD card, so I bought a different brand and eventually got it to work.

Just tried to update firmware to 1.4.6 and now the MATE3s simply won't read any SD card at all. I tried saving my configuration to different SD cards and the MATE just keeps saying: "SD Card not inserted."

Really seems like the SD card reader in the MATE3s is toast.

Time to open a warranty ticket with Outback? Or am I missing something?
https://sunnypower.org
provo
Forum Czar
Posts: 720
Joined: Thu Jul 27, 2006 4:34 pm
My RE system: Sixteen Evergreen EC-120
(4 strings, total 1920W)
Eight Rolls S-550 (2 strings, total ~800Ah @ 24V)
One FM80
One VFXR3524A
Hub 10
Mate3s
FNDC and Trimetric
Honda EU3000is generator
Location: Sierra foothills

Re: MATE3s can't read SD cards anymore

Post by provo »

I only know a couple tricks:

1. Erase and reformat the SD card as MS-DOS. I have to do that every time, since I use a Mac.
2. Do the bootloader approach -- unplug CAT5, insert the card, plug the CAT5 back in while holding the UP key.
User avatar
Megunticook
Forum Guru
Posts: 266
Joined: Fri Sep 29, 2017 4:08 am
My RE system: 6.4 kW solar array (21 QCell 305 panels in strings of 3)
GS8048A FLEXpower Radian (Radian 8048A, 2 FlexMax 80 cc's, Mate 3s, FlexNet DC, Hub)
8x6v Rolls-Surette 550 FLA batteries, 428AH
Location: Maine
Contact:

Re: MATE3s can't read SD cards anymore

Post by Megunticook »

Thanks, I'll try those tricks.

Is yours giving you problems?

I should probably open a ticket with OB and see if they'll honor the warranty though. Will report back with results.

Seems like the MATE3s has been a chronic headache for Outback--maybe time to find a better manufacturer with higher QA standards.
https://sunnypower.org
provo
Forum Czar
Posts: 720
Joined: Thu Jul 27, 2006 4:34 pm
My RE system: Sixteen Evergreen EC-120
(4 strings, total 1920W)
Eight Rolls S-550 (2 strings, total ~800Ah @ 24V)
One FM80
One VFXR3524A
Hub 10
Mate3s
FNDC and Trimetric
Honda EU3000is generator
Location: Sierra foothills

Re: MATE3s can't read SD cards anymore

Post by provo »

Megunticook wrote: Tue Apr 13, 2021 5:59 am Thanks, I'll try those tricks.

Is yours giving you problems?
Not since I started following both those recommendations every time I update firmware. Before that it was a constant problem ....
Mike Curran
Forum Emperor
Posts: 2278
Joined: Sat Aug 28, 2004 6:28 pm
My RE system: Outback - Garage roof:
- 8 (2x4) Evergreen 180's into one FM80 (2007/2020 - replaced MX60)
- 6 (2×3) ALEO S79-300's into one FM80 (2017)
- 2 grid-tied VFXR3524A-01's series stacked, replaced GVFX's (2020)
- 12 Surrette/Rolls 2V x 1766Ah (2007)
- Hub10.3, Mate3s, FNDC, RTS. Tigo ES maximizers on each PV module.

Westinghouse Solar - Barn roof: (2012)
- 30 (2x15) 235W panels with Enphase M215 microinverters, grid-tied

Outback Skybox - Barn roof: (2019)
- 14 Talesun 275W in series (DC array input to SB inverter/charger)
- 3 SimpliPhi 3.8 batteries, 48V, 225Ah total
- AC coupled input from 14 Talesun 275W, Enphase M215 microinverters

All self-designed and self-installed
Location: Chagrin Falls, Ohio

Re: MATE3s can't read SD cards anymore

Post by Mike Curran »

I'm still running 1.4.2 and no problems. I went to see what 1.4.6 changed and the list of known issues makes me wonder, why do the upgrade? Then I looked at the previous updates (1.4.3 & .5) and still wasn't encouraged to change anything. I haven't experienced the problems these updates are designed to fix, so why update? Any advice?
Screenshot_20210416-165817_Samsung Internet.jpg
https://smart.tigoenergy.com/p/pZXn7SZQyO45?date=2021-04-19
https://enlighten.enphaseenergy.com/public/systems/Hctc107221
User avatar
Megunticook
Forum Guru
Posts: 266
Joined: Fri Sep 29, 2017 4:08 am
My RE system: 6.4 kW solar array (21 QCell 305 panels in strings of 3)
GS8048A FLEXpower Radian (Radian 8048A, 2 FlexMax 80 cc's, Mate 3s, FlexNet DC, Hub)
8x6v Rolls-Surette 550 FLA batteries, 428AH
Location: Maine
Contact:

Re: MATE3s can't read SD cards anymore

Post by Megunticook »

Hmmmm...I suppose one approach is "if it ain't broke don't fix it."

Having worked with computers for a couple decades now, I tend to update more often than not--but always leave an easy path to roll back in case the update goes south.

I opened a ticket with OB support on my SD card issue and they're sending a replacement unit.
https://sunnypower.org
Mike Curran
Forum Emperor
Posts: 2278
Joined: Sat Aug 28, 2004 6:28 pm
My RE system: Outback - Garage roof:
- 8 (2x4) Evergreen 180's into one FM80 (2007/2020 - replaced MX60)
- 6 (2×3) ALEO S79-300's into one FM80 (2017)
- 2 grid-tied VFXR3524A-01's series stacked, replaced GVFX's (2020)
- 12 Surrette/Rolls 2V x 1766Ah (2007)
- Hub10.3, Mate3s, FNDC, RTS. Tigo ES maximizers on each PV module.

Westinghouse Solar - Barn roof: (2012)
- 30 (2x15) 235W panels with Enphase M215 microinverters, grid-tied

Outback Skybox - Barn roof: (2019)
- 14 Talesun 275W in series (DC array input to SB inverter/charger)
- 3 SimpliPhi 3.8 batteries, 48V, 225Ah total
- AC coupled input from 14 Talesun 275W, Enphase M215 microinverters

All self-designed and self-installed
Location: Chagrin Falls, Ohio

Re: MATE3s can't read SD cards anymore

Post by Mike Curran »

I opened a ticket with OB support on my SD card issue and they're sending a replacement unit.
Good news! Sounds like it was easy.
https://smart.tigoenergy.com/p/pZXn7SZQyO45?date=2021-04-19
https://enlighten.enphaseenergy.com/public/systems/Hctc107221
User avatar
Megunticook
Forum Guru
Posts: 266
Joined: Fri Sep 29, 2017 4:08 am
My RE system: 6.4 kW solar array (21 QCell 305 panels in strings of 3)
GS8048A FLEXpower Radian (Radian 8048A, 2 FlexMax 80 cc's, Mate 3s, FlexNet DC, Hub)
8x6v Rolls-Surette 550 FLA batteries, 428AH
Location: Maine
Contact:

Re: MATE3s can't read SD cards anymore

Post by Megunticook »

I just reported the issue and they immediately offered to send a replacement. Appreciate their responsiveness.

This will actually be the second warranty replacement for the MATE3s--the first one got shipped back to them the first month I put the system online. Based on my experience and what I've seen on the forums, the MATE3s has been a gigantic headache for Outback--probably countless hours of support time and lots of MATEs getting returned.

Hopefully they take the lesson and either improve the engineering (if that's the issue) or go with a better supplier with stronger QA.
https://sunnypower.org
User avatar
Megunticook
Forum Guru
Posts: 266
Joined: Fri Sep 29, 2017 4:08 am
My RE system: 6.4 kW solar array (21 QCell 305 panels in strings of 3)
GS8048A FLEXpower Radian (Radian 8048A, 2 FlexMax 80 cc's, Mate 3s, FlexNet DC, Hub)
8x6v Rolls-Surette 550 FLA batteries, 428AH
Location: Maine
Contact:

Re: MATE3s can't read SD cards anymore

Post by Megunticook »

Update--the new MATE3s arrived. I took a shot at saving the configuration file from the old MATE3s so I could just load it onto the new MATE--wouldn't read the SD card but then for kicks I told it to "restore" configuration instead of "save" and suddenly the SD card reader seemed to start working. So I saved my configuration, then I figured I'd go ahead and try updating the firmware, which also worked.

Hmmmm...maybe I don't need the new MATE after all. Will send it back I guess.

Strange. The MATE3s certainly has issues.
https://sunnypower.org
Post Reply